Go Back   KCSR - THE Kansas City Forum > Automotive Forums > Domestic Tech

Reply
Thread Tools
Unread 2016-09-20, 07:05 PM   #1
MustangsRKool
 
Join Date: Sep 2016
Posts: 6
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Dislikes (Given): 0
Dislikes (Received): 0
Default Mustang dropping RPMs at IDLE

https://giphy.com/gifs/mustang-l3vR8CwKdfeq7bQys

02 Mustang GT only mods are K&N air filter and a catback exhaust. The RPMs drop at idle with or without the AC on. I've cleaned the Throttle body and MAF. I've put seafoam in my tank with a fresh tank of gas and in my oil still with no avail.

Any info is appreciated and my user name is something that my gf thought up, please don't judge.

Thanks!
MustangsRKool is offline   Reply With Quote
Unread 2016-09-20, 11:48 PM   #2
Kyle Bryan k
 
Join Date: Jul 2009
Posts: 1,565
Post Thanks / Like
Thanks (Given): 84
Thanks (Received): 41
Likes (Given): 446
Likes (Received): 181
Dislikes (Given): 2
Dislikes (Received): 8
Default

iacv?
Kyle Bryan k is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

 

All times are GMT -5. The time now is 08:15 AM.


Design By: Miner Skinz.com
Powered by vBulletin® Version 3.13.37
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Copyright (c) 1993-2012, KCSR.org